阿里云云体检通用代码补丁,有效防护XSS,sql注射,代码执行

2016-12-27 00:34:26 admin 38

asp.zip

php_patch.zip

版本:v1.1 
更新时间:2013-05-25 
更新内容:优化性能 
功能说明: 

可以有效防护XSS,sql注射,代码执行,文件包含等多种高危漏洞。

使用说明:

1、将waf.php传到要包含的文件的目录

2、在页面中加入防护,有两种做法,根据情况二选一即可:

a).在所需要防护的页面加入代码

require_once('waf.php');

就可以做到页面防注入、跨站

如果想整站防注,就在网站的一个公用文件中,如数据库链接文件config.inc.php中!

添加require_once('waf.php');来调用本代码


常用php系统添加文件

PHPCMS V9 phpcmsase.php

PHPWIND8.7 datasql_config.php

DEDECMS5.7 datacommon.inc.php

DiscuzX2   configconfig_global.php

Wordpress   wp-config.php

Metinfo   includehead.php


b).在每个文件最前加上代码

在php.ini中找到:

Automatically add files before or after any PHP document.

auto_prepend_file = waf.php路径;